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How to convert a CAD file to 3D Printable STL format:
Overview:
The STL file is a rapid prototyping standard data output.
Different types of software are used to design a 3D model but for printing we need a file with STL
extension for better production monitoring.
Here are a few TIPS & GUIDELINES while converting your CAD designs to 3D PRINTABLE
STL file from different CAD platform software is used to design a 3D model but for printing we
need a file with STL extension for better production monitoring.
Autodesk Inventor
1.
Go to the File menu, then select the ‘Save Copy As’ option
2.
Select STL from the Types drop-down
3.
Click the Options button, and choose the High detail level
4.
Click the Save Button
Autodesk Inventor allows you to save both individual parts and assemblies in STL format, at all
design levels.
Phase 1: Saving a model design in STL format
Autodesk Inventor model design as an STL file:
1.
From the Tools menu, select Rebuild All. This ensures that the design data contains recent
changes, and that it is not corrupt.
2.
From the File menu, select Save Copy As… > To Save copy as dialoge box opens
3.
In the Save as type field, select STL Files (*.stl), and click Options. The STLOut Save
Options dialog box opens.
4.
Select High and click OK.
5.
In the Save Copy As dialog box, click Save.
6.
Note: To change the values associated with each of the resolution settings
(High/Medium/Low) you need to edit the Windows registry
Google Sketch Up:
:
You will need an STL “exporter” plug in for SketchUp.
1. Install the plugin, using the installation instruction
2. After you have installed the plugin, reopen SketchUp and select the object to be 3D printed (by
triple clicking or whatever method you prefer, so long as the entire object is highlighted in blue).
3. Click on the drop down menu for “TOOLS” and select “EXPORT TO DXF OR STL”
4. Select export unit as “MILLIMETERS”
5. Select “stl”
6. When the save file name window opens and you type in the name – be sure to type the extension
“.stl” to the end of the name. This may not be necessary depending on what version you have.
7. After it has saved the STL file, you will see a window pop up like this.
Now that you have just saved your first STL file! Now, before you slice the STL file into G Code,
let’s make sure it is watertight by using MeshLab.
PROEngineer ( PRO E):
1. File> save a copy
2. Set type to STL
3. Set chord height to 0 the field will be replaced by minimum acceptable value
4. Set Angle control to 1
5. Choose file Name
6. Ok
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Unigraphics:
1. File>Export>Rapid prototyping
2. Set output type to Binary
3. Set angle tolerance to .0025
4. Set Adjacency Tolerance to .12
5. Set Normal Gen to 0
6. Set normal display to off
7. Set Triangle display on
SolidWorks:
1.
File > Save As
2.
Set Save As Type to STL
3.
Options > Fine > OK
4.
Save
5.
STL settings: How to change STL settings
6.
File > Save As
7.
STL > Options
8.
For a smoother STL file, change the Resolution to Custom
9.
Change the deviation to 0.0005in (0.01 mm)
10.
Change the angle to 5 (Smaller deviations and angles will produce a smoother file, but the
file size will get larger)
Solid Works 2000
Solid Works allows you to save model designs in STL format, at all levels of design, for both
individual parts and assemblies, including the ability to save a multi-bodied model as a single STL.
To save a model or a model assembly in STL Format:
1.
From the File menu, select Save as. The Save As dialog box opens.
2.
From the Save as type drop-down menu, select STL (*.stl).
3.
Click Options... The Export Options dialog box appears, and the model is displayed in
tessellated view. STL is the File Format selection.
4.
In the Export Options dialog box, in the “Output as” section, select Binary. (The resulting
file size will be much smaller than a file saved in ASCII format.)
5.
In the “Resolution” section, select the appropriate option. If you select Custom, you can
manually adjust the Deviation and Angle settings, as needed. As a rule, the higher the
resolution, the larger the size of the file, and the longer it takes to generate.
6.
For Single Material Builds make sure that the following check box is selected: Save all
components of an assembly in a single file. This ensures that all components are saved as a
single STL file.
7.
For Dual Material Builds make sure that the following check box is NOT selected: Save all
components of an assembly in a single file. This ensures that all components are saved as
separate STL files.
8.
Click OK.
9.
In the Save As dialog box, click Save.
10.
In the confirmation message, click Yes.
Catia:
1.
Select STL command
2.
Maximum Seg to 0.0125mm
3.
Select the model and > select Yes
4.
Select Export > type File name > OK
Catia can import almost any design-file format, but only those that include solid data (IGES, STEP,
Para solid, etc.)
STL files can be saved – with a special add-on module. Catia V5 is capable of creating STL files from
parts (CatiaPART files), but not from assemblies (CatiaPRODUCT files) or geometrical
representations (car files). Therefore, source files, including those saved in a neutral format (STEP
or IGES, for example), must be saved as parts. If the source design was saved as an assembly, it is
imported to Catia as a product.
To create an STL file from it, you must first convert it to a multi-bodied part. The procedure
described below is one of sever several methods for doing this.
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Phase 1: Saving a model design in STL format
Opening and Preparing the Source File:
1.
From the File menu, select Open, and open the source file. If the source design was saved as
an assembly, it is imported as a Catia PRODUCT model.
2.
Save the product file.
3.
From the File menu, select New > Part, and give it the name of one of the components.
4.
In the product window, select this component, and copy it (with the Edit menu or the rightclick pop-up menu).
5.
In the part window, paste the component.
6.
Repeat steps and until you have copied all of the components and pasted them as individual
parts. Figure on the right shows the result of pasting the components of the product into individual
part files.
7.
From the File menu, select New > Part, and give it a name suitable for the combined model.
8.
Copy each of the individual components (parts) from the working files and paste them into
the new (combined) model file.
Since the geometries of all of the parts are retained, they should be aligned correctly in the combined
part. The new part is now ready to be exported as an STL file.
Phase 2: Re-aligning parts (if necessary)
Occasionally, because of the way the original assembly was designed, some of the components may
not align correctly in the combined part. If so, you must align them, using the Constraints feature,
from the Insert menu.
Before saving the file, it is advisable to review the settings that determine the accuracy of the model
– and the size of the file. To see these parameters:
1.
From the Tools menu, select Options.
2.
In the Options dialog box, display the Performance tab.
3.
Under the General category (on the left), select Display.
4.
Pay attention to the 3D Accuracy settings.
Fixed – The lower the setting, the finer the details of the model in the STL file. A very small setting
results in a very large STL file. Curves’ accuracy ratio – The higher the setting, the smoother the
surface will be, when dealing with complex geometries, especially if surfaces contain sudden small
changes with small radii (like the bumps on a golf ball).
Phase 3: Saving the Part as an STL File
After preparing the part, as described above, proceed as follows:
1.
From the File menu, select Save As.
2.
In the Save As dialog box, select stl from the Save as type pull-down list.
3.
Click Save.
Rhino:
1.
File > Save As
2.
Select File Type to STL
3.
Select File Name > Save
4.
Select Binary
5.
Select Detail Controls from Mesh Options
6.
Max Angle = 20, Max aspect ratio = 6, Min edge Length = 0.0001
7.
OK
McNeel Rhino - version 3 and later:
Rhino enables extensive control of STL properties when saving designs as STL files.
Because Rhino software is surface-based, the complete model design (even if an assembly) is saved as
a single STL part.
Saving a model design in STL format
1.
Open the model design in Rhino.
2.
From the File menu, select Save As. The Save dialog box opens.
3.
In the File name box, enter a name for the new STL file.
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4.
In the Save as type box, select Stereo lithography [*.stl].
5.
Click Save.
6.
In the STL Mesh Export Options dialog box, set the STL tolerance – the maximum
distance allowed between the surface of the design and the polygon mesh of the STL file.
In the Polygon Mesh Detailed Options dialog box, set the STL tolerance in the field- labelled
Maximum distance, edge to surface, as shown in the figure. If you do not know the other settings
appropriate for your model design, try these:
Maximum angle – clear
Maximum aspect ratio – clear
Maximum distance edge to surface (Tolerance) – less than half of the printer’s resolution.
For example, the setting shown in the figures above (0.01 mm) is a good setting for printing models
at a resolution (0.03 mm).
7.
Click OK.
8.
In the STL Export Options dialog box, set the file type as Binary and click OK.
If the Export open objects check box is selected, STL files will be created for each of the objects
currently open. If this check box is cleared, an STL file is created for the selected object.
Important: STL files are suitable for 3D printing if the models they describe are "watertight" - that
is, they do not contain holes or gaps. If the following message appears, click Cancel and fix the
model design before saving it as an STL file.
Troubleshooting Model Designs
If a model design contains holes or gaps, it is not suitable for 3D printing. Before saving it as an
STL file, you must make it “watertight.”
To close holes and gaps in a model design:
1.
Select the entire object.
2.
From the Edit menu, select Join.
or – Click the Join icon on the side toolbar. This command reduces the number of surfaces and fits
them together tightly. (The entities are not fused together into one unit.) The message in the
command bar indicates this.
3.
Select the object. You can select the entire object, but to save time, you may select only the
problematic entity.
4.
From the Tools menu, select Polygon Mesh > From NURBS Object. or – Click the Mesh
from Surface/Poly surface icon on the side toolbar. The Polygon Mesh Options dialog box opens.
5.
Click Detailed Controls… The Polygon Mesh Detailed Options dialog box opens.
6.
Enter the same settings as before and click OK.
7.
Select the entire object.
8.
From the Tools menu, select Polygon Mesh > Weld.
9.
In the command bar, type 180 for the angle tolerance, and press Enter. With an angle
tolerance of 180, the Weld command always merges adjacent triangle points.
10.
From the Tools menu, select Polygon Mesh > Unify Normals. This setting unifies the
normals of all triangles, so that they have the same definition for “up.”
11.
To validate that the object is watertight, type SelNakedMeshEdgePt in the command bar,
and press Enter. If the resulting object contains holes or gaps, the mesh point is highlighted in the
display.
12.
Repeat the Save As procedure
Solid Edge
Open Model & select File > Save As
Select File type as STL
Options > conversion tolerance to 0.015 mm
Surface Plane Angle > 45°
Select Binary type and OK
Name & Save STL file
Solid Edge - version 16 and later
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Solid Edge software from Siemens PLM (formerly USG) supports STL output at the core level,
enabling you to save both parts and assemblies as STL files. Note, however, that when saving an
assembly, all of its components are included in a single STL file.1
Phase 1: Saving a model design in STL format
From the File menu, click Save As. The Save As dialog box opens.
From the Save as type drop-down menu, select STL documents (*.stl) and click Options... The STL
Export Options dialog box opens.
Set Conversation tolerance and Surface plane angle to appropriate values for your model. The lower
the Conversation tolerance, the finer the tessellation. The lower the Surface plane angle, the greater
the accuracy (noticeable in small details). As a rule, the finer the tessellation and the greater the
accuracy, the larger the size of the STL file, and the longer it takes to generate it.
In the Output file as section, select Binary. Binary STL files are much smaller than STL files saved
in ASCII format.
Click OK.
In the Save As dialog box, click Save.
Keep the surface to smooth
For sturdy and reliable built with FDM process, use minimum wall thickness of 2mm and minimum
feature size to 1mm.
Keep the minimum tolerance to 1mm
If you are design includes structure with overhangs, please ensure you provide a good solid base
Save you file with a flat base
Solid Edge is technically capable of creating individual STL files from the components of an
assembly, but this functionality is not built into the program. It is achieved through the application
programming interface (API), using Visual Basic scripts. This solution does not enable a visual
preview of the polygon mesh before saving the STL files.

-
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